HomeFront Sales Server Outage

Incident Report for External Status Page

Resolved

Our service provider has rebooted the affected servers, and HomeFront Sales is now back up and running.

We will continue to monitor the environment to ensure system stability. Thank you for your patience.
Posted May 13, 2026 - 14:45 CDT

Investigating

We are currently experiencing an outage affecting the HomeFront Sales Server. Our service provider has been engaged and is actively investigating the issue to restore service as quickly as possible.

We will provide additional updates as more information becomes available.
Posted May 13, 2026 - 14:28 CDT
This incident affected: HomeFront Sales.