Apple iOS 18 - BuildPro Mobile Application
Incident Report for External Status Page
Resolved
We now have an updated version of the mobile application available that addresses the issues from the iOS 18 release.
Posted Sep 20, 2024 - 15:36 CDT
Identified
As most of you know, Apple typically releases a major iOS upgrade each fall. According to Apple, the iOS 18 release date is September 16. After testing the BuildPro mobile app with the beta versions of the upcoming iOS 18 over the last few months, we have identified some required UI updates that must be made to ensure the BuildPro mobile app runs effectively.

At this time, we strongly advise against installing iOS 18 on any devices used by the BuildPro mobile application until our final testing is complete and a production build is released to the Apple App Store.

Users can still use the mobile browser on their device to access BuildPro directly and make updates on the website as needed.

We appreciate your patience and understanding as we work through these latest updates from Apple.

UPDATE Friday 9/13/24:

We now have an updated version of the BuildPro mobile application available in TestFlight (5.34.3(3)) for UAT testing. This version addresses the compatibility issues with the iOS 18 release candidate Apple pushed recently. We plan to release this version to all production users no later than Friday, September 20. Please start testing as soon as possible and provide your feedback. Once your testing is complete, please let us know. If we receive positive testing results in UAT from heavy mobile users before this date, we may release it sooner.
Posted Sep 13, 2024 - 16:22 CDT
This incident affected: BuildPro (Mobile Application).