BuildPro Issues

Incident Report for External Status Page

Resolved

All issues are now resolved.
Posted Apr 13, 2026 - 09:23 CDT

Monitoring

Issues have been identified and corrected. We are continuing to monitor.
Posted Apr 13, 2026 - 09:01 CDT

Investigating

We are currently reviewing issues related to the following:

Mobile App login
EPO creation
Drag and Drop Calendar
Warranty tab not loading
Posted Apr 13, 2026 - 08:31 CDT
This incident affected: BuildPro (Mobile Application, Website).